[OpenWrt-Devel] [PATCH 2/3] ath79: Prepare nand subtarget for SPI-NAND boards under Linux 4.19

Petr Štetiar ynezz at true.cz
Wed May 15 01:05:16 PDT 2019


Jeff Kletsky <lede at allycomm.com> [2019-05-14 15:39:55]:

[ adding Marty (author of ar300m-nand support) to the Cc loop ]

>   * Removed non-functional GL.iNet AR300M NAND target

you've probably missed some parts:

 package/boot/uboot-envtools/files/ath79:glinet,gl-ar300m-nand|\
 target/linux/ath79/base-files/etc/board.d/01_leds:glinet,gl-ar300m-nand|\
 target/linux/ath79/base-files/etc/board.d/02_network:   glinet,gl-ar300m-nand|\
 target/linux/ath79/dts/qca9531_glinet_gl-ar300m-nand.dts:       compatible = "glinet,gl-ar300m-nand", "qca,qca9531";

could you please make this ar300m-nand removal separate commit (probably first
in the series) and add Marty to the Cc?

 Cc: Marty E. Plummer <hanetzer at startmail.com>
 Signed-off-by: Jeff Kletsky <git-commits at allycomm.com>

It would be nice to make him aware about this possible device removal as he
might be interested in fixing of support for this device or in the other case,
he can possibly give you his Acked-by/Reviewed-by tag.

> ---
>  target/linux/ath79/image/nand.mk       | 13 -----------
>  target/linux/ath79/nand/config-default | 32 +++++++++++++++-----------
>  target/linux/ath79/nand/target.mk      | 10 +++++---
>  3 files changed, 26 insertions(+), 29 deletions(-)
> 
> diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
> index eee419194b..e69de29bb2 100644
> --- a/target/linux/ath79/image/nand.mk
> +++ b/target/linux/ath79/image/nand.mk
> @@ -1,13 +0,0 @@
> -define Device/glinet_gl-ar300m-nand
> -  ATH_SOC := qca9531
> -  DEVICE_TITLE := GL-AR300M (NAND)
> -  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
> -  KERNEL_SIZE := 2048k
> -  BLOCKSIZE := 128k
> -  PAGESIZE := 2048
> -  VID_HDR_OFFSET := 512
> -  IMAGES += factory.ubi
> -  IMAGE/sysupgrade.bin := sysupgrade-tar
> -  IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
> -endef
> -TARGET_DEVICES += glinet_gl-ar300m-nand
> diff --git a/target/linux/ath79/nand/config-default b/target/linux/ath79/nand/config-default
> index 738c29c9b1..05a5a8dbd0 100644
> --- a/target/linux/ath79/nand/config-default
> +++ b/target/linux/ath79/nand/config-default
> @@ -1,14 +1,20 @@
> -CONFIG_BCH=y
> -CONFIG_MTD_NAND=y
> -CONFIG_MTD_NAND_BCH=y
> -CONFIG_MTD_NAND_ECC=y
> -CONFIG_MTD_NAND_ECC_BCH=y
> -CONFIG_MTD_SPINAND_MT29F=y
> -CONFIG_MTD_SPINAND_ONDIEECC=y
> +CONFIG_BLK_MQ_PCI=y
> +CONFIG_LEDS_RESET=y
> +CONFIG_MTD_NAND_CORE=y
> +CONFIG_MTD_SPI_NAND=y
>  CONFIG_MTD_UBI=y
> -CONFIG_MTD_UBI_BEB_LIMIT=20
> -# CONFIG_MTD_UBI_BLOCK is not set
> -# CONFIG_MTD_UBI_FASTMAP is not set
> -# CONFIG_MTD_UBI_GLUEBI is not set
> -CONFIG_MTD_UBI_WL_THRESHOLD=4096
> -# CONFIG_UBIFS_FS is not set
> +CONFIG_MTD_UBI_BLOCK=y
> +CONFIG_OF_ADDRESS_PCI=y
> +CONFIG_OF_PCI=y
> +CONFIG_OF_PCI_IRQ=y
> +CONFIG_PCI=y
> +# CONFIG_PCI_AR71XX is not set
> +CONFIG_PCI_AR724X=y
> +CONFIG_PCI_DISABLE_COMMON_QUIRKS=y
> +CONFIG_PCI_DOMAINS=y
> +# CONFIG_PHY_AR7100_USB is not set
> +CONFIG_PHY_AR7200_USB=y
> +CONFIG_UBIFS_FS=y
> +CONFIG_UBIFS_FS_ADVANCED_COMPR=y
> +CONFIG_UBIFS_FS_LZO=y
> +CONFIG_UBIFS_FS_ZLIB=y
> diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
> index 91afe675c5..6ab9748ca4 100644
> --- a/target/linux/ath79/nand/target.mk
> +++ b/target/linux/ath79/nand/target.mk
> @@ -1,9 +1,13 @@
>  BOARDNAME := Generic devices with NAND flash
> -FEATURES += squashfs nand rtc
> +
> +# SPI NAND support requires at least Linux 4.19

You can drop this comment, having this in the commit message is enough.

> +KERNEL_PATCHVER:=4.19
> +
> +FEATURES += squashfs nand
>  
>  DEFAULT_PACKAGES += wpad-basic
>  
>  define Target/Description
> -	Build firmware for Atheros AR71xx/AR913x based boards with
> -	NAND flash, e.g. Netgear WNDR4300.
> +	Firmware for boards based on MIPS 24kc Atheros/Qualcomm SoCs
> +	in the ar72xx and subsequent generations with support for NAND flash
>  endef
> -- 
> 2.20.1



More information about the openwrt-devel mailing list