[OpenWrt-Devel] [PATCH] ath79: Remove NAND targets as no available drivers

lede at allycomm.com lede at allycomm.com
Fri May 10 06:25:45 PDT 2019


From: Jeff Kletsky <git-commits at allycomm.com>

Prior to Linux 4.19 there will be no driver support for SPI NAND

Remove the non-bootable GL.iNet AR300M from nand.mk
so images are not generated.

Based on work with the GL.iNet AR750S, the GL.iNet AR300M, NAND-based
board definition and DTS should be reexamined, as well as the NAND port
completed prior to its reintroduction.

Signed-off-by: Jeff Kletsky <git-commits at allycomm.com>
---
 target/linux/ath79/image/nand.mk | 14 +-------------
 1 file changed, 1 insertion(+), 13 deletions(-)

diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index eee419194b..30e0c72008 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,13 +1 @@
-define Device/glinet_gl-ar300m-nand
-  ATH_SOC := qca9531
-  DEVICE_TITLE := GL-AR300M (NAND)
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
-  KERNEL_SIZE := 2048k
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  VID_HDR_OFFSET := 512
-  IMAGES += factory.ubi
-  IMAGE/sysupgrade.bin := sysupgrade-tar
-  IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
-endef
-TARGET_DEVICES += glinet_gl-ar300m-nand
+# There is no driver support on ath79 for SPI NAND prior to Linux 4.19
-- 
2.11.0




More information about the openwrt-devel mailing list