[OpenWrt-Devel] [PATCH] tegra: add vendor string to device name

Tomasz Maciej Nowak tomek_n at o2.pl
Mon May 6 08:48:46 PDT 2019


W dniu 05.05.2019 o 09:16, Petr Štetiar pisze:
> Tomasz Maciej Nowak <tomek_n at o2.pl> [2019-05-04 14:39:38]:
> 
>> W dniu 03.05.2019 o 13:21, Petr Štetiar pisze:
>>> Tomasz Maciej Nowak <tomek_n at o2.pl> [2019-05-01 19:43:54]:
>>>
>>> Hi,
>>>
>>>> for better identification. Also create SUPPORTED_DEVICES string from it
>>>> which corresponds to dts compatible string.
>>>>
>>>> Signed-off-by: Tomasz Maciej Nowak <tomek_n at o2.pl>
>>>
>>> ...
>>>
>>>>  define U-Boot/trimslice
>>>>    NAME := CompuLab TrimSlice
>>>> -  BUILD_DEVICES := trimslice
>>>> +  BUILD_DEVICES := compulab_trimslice
>>>>    UBOOT_IMAGE := trimslice-mmc.img trimslice-spi.img
>>>
>>> what about this files? Shouldn't you rename them as well?
>>
>> That could be done, but I left it as is, to be in line with cbootimage-configs:
>> https://github.com/NVIDIA/cbootimage-configs/blob/7c3b458b93ed6947cd083623f543e93f9103cc0f/tegra20/compulab/trimslice/trimslice-mmc.img.cfg#L22
> 
> I'm puzzled now, as I don't know much about cbootimage, and this file refers
> to trimslice-mmc.bct so it doesn't make sense to me in this context.

In the first call of cbootimage we create trimslice-mmc.bct. Then in second (final)
call, cbootimage creates from this bct a flashable U-Boot image. Unfortunately the
bct can't be passed as parameter and is red from configuration file I mentioned. So
it is matter of convenience, because we would need to patch the sources or add
additional shell commands.

Regards

-- 
TMN



More information about the openwrt-devel mailing list