[OpenWrt-Devel] [PATCH] ath79: Add SUPPORTED_DEVICES for Archer C7 v1/v2

camden lindsay camden.lindsay+lede at gmail.com
Wed May 1 20:37:39 PDT 2019


Hmmm; well, i've got this; Fresh 'firstboot' on an archer c7 V2, following
version info:
root at LEDE:~# cat /etc/openwrt_*
DISTRIB_ID='LEDE'
DISTRIB_RELEASE='SNAPSHOT'
DISTRIB_REVISION='r3189-12db207'
DISTRIB_CODENAME='reboot'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='LEDE Reboot SNAPSHOT r3189-12db207'
DISTRIB_TAINTS='no-all'
r3189-12db207
root at LEDE:~#

/etc/config/wifi has this in it:
root at LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option disabled '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT20'
option disabled '1'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

and
root at LEDE:/sys/class/ieee80211# ls -al /sys/class/ieee80211/
drwxr-xr-x    2 root     root             0 Jan 27 22:39 .
drwxr-xr-x   21 root     root             0 Jan  1  1970 ..
lrwxrwxrwx    1 root     root             0 Jan 27 22:39 phy0 ->
../../devices/pci0000:01/0000:01:00.0/ieee80211/phy0
lrwxrwxrwx    1 root     root             0 Jan 27 22:39 phy1 ->
../../devices/platform/qca955x_wmac/ieee80211/phy1


After upgrading using sysupgrade to stable ar71xx:
http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/openwrt-18.06.2-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin
root at LEDE:~# cat /etc/openwrt_*
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='18.06.2'
DISTRIB_REVISION='r7676-cddd7b4c77'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 18.06.2 r7676-cddd7b4c77'
DISTRIB_TAINTS=''
r7676-cddd7b4c77
root at LEDE:~#

I should have double checked wireless config but didn't :-/  derp. I'll
rollback to this at the end and post a firstboot'd wireless config from
18.06.2.

PCI paths:
root at LEDE:~# ls -al /sys/class/ieee80211/
drwxr-xr-x    2 root     root             0 Jan 30 12:21 .
drwxr-xr-x   22 root     root             0 Jan  1  1970 ..
lrwxrwxrwx    1 root     root             0 Jan 30 12:21 phy0 ->
../../devices/pci0000:01/0000:01:00.0/ieee80211/phy0
lrwxrwxrwx    1 root     root             0 Jan 30 12:21 phy1 ->
../../devices/platform/qca955x_wmac/ieee80211/phy1

Attempting to sysupgrade to ath79 brings this on:
root at LEDE:~# sysupgrade
/tmp/openwrt-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin
Device archer-c7 not supported by this image
Supported devices: tplink,archer-c7-v2
Image check 'fwtool_check_image' failed.
root at LEDE:~#

Forcing upgrade with -f ... After upgrading using sysupgrade to snapshot
ath79:
http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin

root at LEDE:~# cat /etc/openwrt_*
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='SNAPSHOT'
DISTRIB_REVISION='r9915-d6643aca34'
DISTRIB_TARGET='ath79/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r9915-d6643aca34'
DISTRIB_TAINTS=''
r9915-d6643aca34
root at LEDE:~#


root at LEDE:~# ls -al /sys/class/ieee80211/
drwxr-xr-x    2 root     root             0 May  1 05:25 .
drwxr-xr-x   24 root     root             0 Jan  1  1970 ..
lrwxrwxrwx    1 root     root             0 May  1 05:25 phy0 ->
../../devices/pci0000:00/0000:00:00.0/ieee80211/phy0
lrwxrwxrwx    1 root     root             0 May  1 05:25 phy1 ->
../../devices/platform/ahb/ahb:apb/18100000.wmac/ieee80211/phy1
root at LEDE:~#

wireless config seems to have both new and old paths..
root at LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option disabled '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option htmode 'HT20'
option disabled '1'
option path 'platform/ahb/ahb:apb/18100000.wmac'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'

config wifi-device 'radio2'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option disabled '1'

config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

root at LEDE:~#


And .. sorry its out of order, after downgrading using sysupgrade -F  to
18.06.2, then firstbooting,see as follows
root at OpenWrt:~# grep 18 /etc/openwrt_*
/etc/openwrt_release:DISTRIB_RELEASE='18.06.2'
/etc/openwrt_release:DISTRIB_DESCRIPTION='OpenWrt 18.06.2 r7676-cddd7b4c77'
root at OpenWrt:~#

root at OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option disabled '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT20'
option disabled '1'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

root at OpenWrt:~#




Hope this helps some.  I've never used DTS... Heck, i don't even know which
DTS ya'll are talking about since none of these seem to make sense(
https://en.wikipedia.org/wiki/DTS)... so i'm  not clear on what needs to be
done to test the following... (oh, wait .. device tree source.... still
unsure how to proceed):
"Does anybody want to
> > test what happens if the ath79 C7 v2 DTS enables "pcie0" too? It might
> > work, but it might not (depending on whenever it might end up in a
> > different pci domain like pci0001:00.)."

 c
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20190501/62734880/attachment.html>


More information about the openwrt-devel mailing list