[OpenWrt-Devel] ath10k-ct issues - IBSS mode

Hauke Mehrtens hauke at hauke-m.de
Fri Mar 29 05:55:09 PDT 2019


On 3/29/19 1:43 PM, Ben Greear wrote:
> 
> 
> On 03/29/2019 02:58 AM, Koen Vandeputte wrote:
>>
>> On 26.03.19 19:39, Ben Greear wrote:
>>> On 3/26/19 6:59 AM, Koen Vandeputte wrote:
>>>>
>>>> On 26.03.19 14:50, Ben Greear wrote:
>>>>>
>>>>>
>>>>> On 03/26/2019 03:09 AM, Koen Vandeputte wrote:
>>>>>> Hi Ben,
>>>>>> Following our conversation from yesterday, here is a summary of
>>>>>> all issues seen so far:
>>>>>>
>>>>>> Test setup:
>>>>>>
>>>>>> - Board: Mikrotik RB922
>>>>>> - Hardware used: on-board QCA9882 (QCA988x),  Wave1  2x2 .ac
>>>>>> - firmware's tested: both non-HTT and HTT flavours for qca988x
>>>>>>
>>>>>> Synopsis:
>>>>>> - Setting the interface in IBSS mode results in following errors
>>>>>> and spamming
>>>>>> - Speed is very low (100 kbit/s) upon linking 2 devices in HT20,
>>>>>> long GI
>>>>>
>>>>> Hello,
>>>>>
>>>>> Do you see those SWBA overrun messages on both systems, or just one
>>>>> of them?
>>>>>
>>>>> I'll work on fixing the out-of-my-tree compile for 4.20 today, as
>>>>> well as do
>>>>> a quick test on 4.19 to see if I see that error below.
>>>>>
>>>>> Thanks,
>>>>> Ben
>>>>>
>>>> Hi Ben,
>>>>
>>>> A huge amount of then continuously:
>>>
>>> I updated ath10k-ct (commit-id:
>>> be5c21a82b15d28991500a28f7b2b6840356281f)
>>>
>>> I fixed part of the issue with 4.20 not compiling in openwrt, but the
>>> other part appears to be
>>> a backports issue, and I did not attempt to get that working.
>>>
>> Hi Ben,
>>
>> This is still remaining using 4.20:
>>
>> make[4]: Entering directory
>> '/mnt/ramdisk/koen/firmware/builds/generic_rb922/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/linux-4.14.109'
>>
>>   CC [M]
>> /mnt/ramdisk/koen/firmware/builds/generic_rb922/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/ath10k-ct-2019-03-26-be5c21a8/ath10k-4.20/mac.o
>>
>> /mnt/ramdisk/koen/firmware/builds/generic_rb922/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/ath10k-ct-2019-03-26-be5c21a8/ath10k-4.20/mac.c:
>> In function 'ath10k_mac_register':
>> /mnt/ramdisk/koen/firmware/builds/generic_rb922/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/ath10k-ct-2019-03-26-be5c21a8/ath10k-4.20/mac.c:9772:11:
>> error: 'NL80211_EXT_FEATURE_ACK_SIGNAL_SUPPORT' undeclared (first use
>> in this function); did you mean
>> 'NL80211_EXT_FEATURE_DATA_ACK_SIGNAL_SUPPORT'?
>>            NL80211_EXT_FEATURE_ACK_SIGNAL_SUPPORT);
>>            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>            NL80211_EXT_FEATURE_DATA_ACK_SIGNAL_SUPPORT
>> /mnt/ramdisk/koen/firmware/builds/generic_rb922/build_dir/target-mips_24kc_musl/linux-ar71xx_mikrotik/ath10k-ct-2019-03-26-be5c21a8/ath10k-4.20/mac.c:9772:11:
>> note: each undeclared identifier is reported only once for each
>> function it appears in
> 
> I think you will need to go back to 4.19 based driver, or add a hack to
> #ifdef that code out while compiling
> in openwrt.
> 
> I did a brief test with the 4.19 ct driver and it seems to work OK in my
> test setup.  Since it appears openwrt
> will be stuck on 4.19 for a while, I'll put some more effort into
> keeping my 4.19 tree up to date.
> 
> Also, I found a nasty bug with mgt frames in htt-mgt mode yesterday, and
> uploaded new beta firmware to my
> web page...will post csums and such to this list later today.
> 
> Thanks,
> Ben
> 
> 
Hi,

I have a more recent mac80211 framework from kernel 5.1-rc2 in my
feature branch:
https://git.openwrt.org/?p=openwrt/staging/hauke.git;a=shortlog;h=refs/heads/mac80211-5.0
I plan to merge this after the next release is branched off.

You could try that with ath10k-ct from kernel 4.20.

Hauke



More information about the openwrt-devel mailing list