[OpenWrt-Devel] Native IPv6 Broken in recent trunk

Jo-Philipp Wich jow at openwrt.org
Tue Feb 9 07:39:55 EST 2016


Hi.

> config interface 'lan'
>         option force_link '1'
>         option type 'bridge'
>         option proto 'static'
>         option netmask '255.255.255.0'
>         option ip6assign '64'
>         option dns 'xxxxxxxxxxxxx'
>         option ipaddr '172.18.18.1'
>         option _orig_ifname 'eth0.1 wlan0 wlan0-1 wlan1'
>         option _orig_bridge 'true'
>         option ifname 'eth0.1'
> 
> config interface 'wan'
>         option _orig_ifname 'eth0.2'
>         option _orig_bridge 'false'
>         option proto 'pppoe'
>         option username 'xxxxxxxxxxxxxxxxxxxxxxx'
>         option password 'xxxxxxxxxxxxxx'
>         option peerdns '0'
>         option dns 'xxxxxxxxxxxx'
>         option ifname 'eth0.2'
>         option ipv6 'auto'
> 
> config interface 'wan6'
>         option proto 'dhcpv6'
>         option dns 'xxxxxxxxxxxx'
>         option peerdns '0'
>         option reqaddress 'try'
>         option reqprefix '64'
>         option _orig_ifname '@wan'
>         option _orig_bridge 'false'
>         option ifname 'eth0.2'

This should most likely be either "pppoe-wan" or "@wan",
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel



More information about the openwrt-devel mailing list