[OpenWrt-Devel] OpenWRT broken for some reason in my system

Hannu Nyman hannu.nyman at iki.fi
Mon Nov 9 11:42:25 EST 2015

One more "me too" report:
There was probably something unusual in the last OS kernel update for Ubuntu 
15.10 x64, which has caused some compiler tools to require re-installation.

I updated Ubuntu 15.10 kernel last week along other updates offered by the 
system, and after the kernel update I ran a command to purge old kernels, 
like I always do after kernel updates. At that point I noticed that 
exceptionally also a few of the build tools/prerequisities of Openwrt got 
uninstalled at the same time. Almost like there had been a forced dependency 
to the previous kernel version. Normally only the old kernel modules are 
purged, so this looked strange.

I re-installed the Openwrt prerequisities (gcc-multilib, flex, git-core, 
gettext, libssl-dev, ...). Not all of those needed re-installation, but some 
did. So some of them had been really uninstalled. Since then the things have 
been normal again.

Your situation pretty much matches what I would probably have seen if I had 
not re-installed the prerequisities.
Just try reinstalling the ~20 prerequisities for Openwrt and see if that helps.

I don't think that this has anything to do with Openwrt itself.

On 9.11.2015 17:00, Carlos Ferreira wrote:
> not even a distclean was able to solve the problem. I still have the issue.
> On 9 November 2015 at 14:56, Carlos Ferreira <carlosmf.pt at gmail.com 
> <mailto:carlosmf.pt at gmail.com>> wrote:
>     Yes, I agree it may be a problem related to an OS update because I
>     actually did that.
>     Meanwhile, why would the gcc verification fail?
>     I'm using The multilib gnu compiler and it always worked until now..
>     On 9 November 2015 at 14:29, Kevin Darbyshire-Bryant
>     <kevin at darbyshire-bryant.me.uk <mailto:kevin at darbyshire-bryant.me.uk>>
>     wrote:
>         On 09/11/15 13:43, Carlos Ferreira wrote:
>         > PS: Instead of "trunk repo", it's "15.05 repo".
>         >
>         > On 9 November 2015 at 13:42, Carlos Ferreira
>         <carlosmf.pt at gmail.com <mailto:carlosmf.pt at gmail.com>
>         > <mailto:carlosmf.pt at gmail.com <mailto:carlosmf.pt at gmail.com>>> wrote:
>         >
>         >     Today I updated my OpenWRT trunk repo and after making the usual
>         >     "./scripts/feeds install -a" this happened.
>         >
>         >     [claymore at Claymore 15.05]$ ./scripts/feeds install -a
>         >     Checking 'working-make'... ok.
>         >
>         I had some really weird stuff happen very recently with regard to make
>         on 2 mint boxes I use to compile openwrt.  a 'make clean' in
>         scripts/config got me up and running again.  Never seen anything quite
>         like it before!  I think it was an OS update that did it rather than
>         anything openwrt.
>         Kevin
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list