[OpenWrt-Devel] AsiaRF AWM002 (ramips) USB and reboot broken at r44044

Christian Lamparter chunkeey at googlemail.com
Tue Feb 3 02:36:10 EST 2015


On Tue, Feb 3, 2015 at 7:48 AM, Mingyu Li <igvtee at gmail.com> wrote:
>> Russell> I just wanted to give a heads up that I built trunk r44245 last
>> Russell> night and discovered two problems: reboot no longer works, and
>> Russell> USB fails to enumerate a usb-serial device that worked
>> Russell> previously (specifically a pl2303).  To successfully reset, a
>> Russell> power cycle is required.  These problems were not evident the
>> Russell> last time I built, about 3 weeks ago, r43960.  The lsmod output
>> Russell> is nearly identical between working/not-working (with some
>> Russell> minor fuzz in a few module sizes).
>> Russell> I'm planning to try bisecting this, but if someone knows the
>> Russell> problem and beats me to it, I'd be grateful.  Bisecting is
>> Russell> powerful but somewhat tedious. ;-)
>> I bisected the problem.  It appears the bad commit is r44044 (r44043 is
>> good).  The reset and usb problems appear at the same commit.

I ran into a similar issue (usb enumeration) with a RT5350 device
around that time, but as Mingyu Li said, I traced it down to the USB
code and made a patch (It should be pending in blogic queue?):
<https://patchwork.ozlabs.org/patch/432628/> "[PATCH] ralink: fix USB
host function for Intenso M2M"

Thing is: ralink-phy.c can use some more work!

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list