<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style></head><body lang=EN-GB link=blue vlink="#954F72"><div class=WordSection1><p class=MsoNormal>Greetings all</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Having failed to upgrade the memory on my ‘winder, I’m now attempting to upgrade the hard drive as the existing one is too noisy.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I’ve upgraded the firmware to 2.3.3 (thanks Ralph!) and fitted a 120GB PNY SSD with an IDE-SATA bridge. All very cheap. At boot time the ROM recognises it as a PNY 120GB drive but says none of the partitions are ext2. To initialise it I have created four partitions of arbitrary size then used dd to read the old disk’s three partitions into files. Then dd the files to the new partitions. This causes a problem as I am left with a bunch of errors when looking at the new drive in gparted – because they’re bigger than they are supposed to be – and gparted will not repair them.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>The fourth partition has the Nw9 tar file uncompressed onto it. This was formatted as ext2 by gparted.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>However, as I said, no partition can be read by the boot ROM.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I’m now attempting to dd the whole disk into a file to transfer to the SSD. Hopefully I can then use the remaining space to build a partition for the NW9 files. Will this copy the partition layout as well?</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Any advice would be welcome!</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Ultimately I want to get Debian on it but I really have no idea about that..</p></div></body></html>