[PATCH v7 06/70] mips: Rename mt_init to mips_mt_init

Liam Howlett liam.howlett at oracle.com
Mon Apr 4 07:35:29 PDT 2022


Move mt_init out of the way for the maple tree.
Use mips_mt prefix to match the rest of the functions in the file.

Signed-off-by: Liam R. Howlett <Liam.Howlett at oracle.com>
---
 arch/mips/kernel/mips-mt.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/mips/kernel/mips-mt.c b/arch/mips/kernel/mips-mt.c
index d5f7362e8c24..dc023a979803 100644
--- a/arch/mips/kernel/mips-mt.c
+++ b/arch/mips/kernel/mips-mt.c
@@ -230,7 +230,7 @@ void mips_mt_set_cpuoptions(void)
 
 struct class *mt_class;
 
-static int __init mt_init(void)
+static int __init mips_mt_init(void)
 {
 	struct class *mtc;
 
@@ -243,4 +243,4 @@ static int __init mt_init(void)
 	return 0;
 }
 
-subsys_initcall(mt_init);
+subsys_initcall(mips_mt_init);
-- 
2.34.1



More information about the maple-tree mailing list