Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
H. Peter Anvin
hpa at zytor.com
Fri Jul 3 14:01:29 PDT 2026
On July 3, 2026 1:52:43 PM PDT, Thomas Gleixner <tglx at kernel.org> wrote:
>On Fri, Jul 03 2026 at 13:59, Kevin Brodsky wrote:
>> On 03/07/2026 12:27, Michal Suchánek wrote:
>>>> If we're changing the return type, it might be worth renaming the
>>>> function something like:
>>>>
>>>> seccomp_permits_syscall()
>>> Then not only it is clear which way the boolean value should be
>>> interpreted, it also pervents the accidental inversion of existing
>>> calls. Overall great.
>>
>> Totally agreed, if we have the opportunity to rename a completely
>> undescriptive function name like "secure_computing" we should take it.
>
>Absolutely no objections from my side on that.
>
Hell yes.
More information about the linux-um
mailing list