[PATCH] um: use swap() to make code cleaner
Anton Ivanov
anton.ivanov at cambridgegreys.com
Thu Nov 4 07:11:22 PDT 2021
On 04/11/2021 06:16, davidcomponentone at gmail.com wrote:
> From: Yang Guang <yang.guang5 at zte.com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
>
> Reported-by: Zeal Robot <zealci at zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5 at zte.com.cn>
> ---
> arch/um/os-Linux/sigio.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/arch/um/os-Linux/sigio.c b/arch/um/os-Linux/sigio.c
> index 9e71794839e8..1eb15f3cfdc8 100644
> --- a/arch/um/os-Linux/sigio.c
> +++ b/arch/um/os-Linux/sigio.c
> @@ -50,7 +50,7 @@ static struct pollfds all_sigio_fds;
>
> static int write_sigio_thread(void *unused)
> {
> - struct pollfds *fds, tmp;
> + struct pollfds *fds;
> struct pollfd *p;
> int i, n, respond_fd;
> char c;
> @@ -77,9 +77,7 @@ static int write_sigio_thread(void *unused)
> "write_sigio_thread : "
> "read on socket failed, "
> "err = %d\n", errno);
> - tmp = current_poll;
> - current_poll = next_poll;
> - next_poll = tmp;
> + swap(current_poll, next_poll);
> respond_fd = sigio_private[1];
> }
> else {
>
You should include minmax.h for the swap macro. While there is a very significant likelihood that it will be pulled up by another something else, it is better to do that explicitly.
--
Anton R. Ivanov
Cambridgegreys Limited. Registered in England. Company Number 10273661
https://www.cambridgegreys.com/
More information about the linux-um
mailing list