garbled screen with RPI4 on 5.10-rc2

Maxime Ripard maxime at
Thu Nov 5 11:12:34 EST 2020

On Mon, Nov 02, 2020 at 11:19:57PM +0100, Lucas Nussbaum wrote:
> Hi,
> I'm getting a half-garbled screen with an RPI4 on linux 5.10-rc2 (which
> includes Maxime Ripard's changes to the VC4 DRM driver).
> Photo:
> dmesg output:
> Including:
> [    0.000000] Kernel command line: video=HDMI-A-1:1920x1080M at 60,margin_left=48,margin_right=48,margin_top=48,margin_bottom=48 dma.dmachans=0x71f5 bcm2709.boardrev=0xd03114 bcm2709.serial=0x99e79233 bcm2709.uart_clock=48000000 bcm2709.disk_led_gpio=42 bcm2709.disk_led_active_low=0 smsc95xx.macaddr=DC:A6:32:BE:A2:01 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=tty0 console=ttyS1,115200 root=/dev/mmcblk1p2 rw elevator=deadline net.ifnames=0  rootwai
> This is with a Debian image from, where I just
> upgraded the kernel. I also tried updating *.{dat,elf,bin} from
>, but it did not
> help.
> Any ideas?

I tried running the daily image you pointed at, but it looks like it's
running a 5.9 kernel from simplefb, and with nothing to update in apt,
how did you upgrade to that 5.10 kernel?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <>

More information about the linux-rpi-kernel mailing list