[PATCH 2/7] clocksource: Rename CLOCKSOURCE_OF_DECLARE
arnd at arndb.de
Mon May 29 01:41:52 PDT 2017
On Sat, May 27, 2017 at 11:58 AM, Daniel Lezcano
<daniel.lezcano at linaro.org> wrote:
> The CLOCKSOUCE_OF_DECLARE macro is used widely for the timers to declare the
> clocksource at early stage. However, this macro is also used to initialize
> the clockevent if any, or the clockevent only.
> It was originally suggested to declare another macro to initialize a
> clockevent, so in order to separate the two entities even they belong to the
> same IP. This was not accepted because of the impact on the DT where splitting
> a clocksource/clockevent definition does not make sense as it is a Linux
> concept not a hardware description.
> On the other side, the clocksource has not interrupt declared while the
> clockevent has, so it is easy from the driver to know if the description is
> for a clockevent or a clocksource, IOW it could be implemented at the driver
> So instead of dealing with a named clocksource macro, let's use a more generic
> one: TIMER_OF_DECLARE.
> The patch has not functional changes.
> Signed-off-by: Daniel Lezcano <daniel.lezcano at linaro.org>
Could you either leave the old name as an alias for one release, or introduce
the new name as an alias now for 4.13?
I think that that would make it easier to merge new drivers. Otherwise this
looks good to me,
Acked-by: Arnd Bergmann <arnd at arndb.de>
More information about the linux-rpi-kernel