4.10-rc3 rpi issues

Gerd Hoffmann kraxel at redhat.com
Mon Jan 16 02:53:13 PST 2017


> > I've connected the keyboard b/c ssh login over wifi stopped working.  It
> > happens with only two devices (builtin ethernet and wifi, both
> > highspeed) too.
> Does the issue occures if all USB devices are already connected before power up?


> > And, yes, 4.9 dwc2 has no problems handling all three devices.
> Could you please bisect this issue?

Hmm, that appears to be quite a challenge.  Behavior isn't very
consistent ...

 * On 4.9.x wifi works every time.
 * On 4.10-rc3 wifi fails every time, silently (i.e. no errors
   in the logs).

While trying to bisect things I've seen (additionally to the two above):

 * failure to load the firmware.
 * wlan0 trying to connect to ap, but timing out.

Sometimes even the very same kernel showed different behavior when
booted multiple times.

USB not working reliable can certainly explain all the different error
cases above, so I decided to rate a kernel as "good" if it worked fine
three boots in a row and "bad" otherwise, no matter how it failed.  That
landed at commit 288660b88deee3c625f1c17d16bdd690bffe35c7.  Some virtio
patch.  Looks bogus.  Nevertheless tried v4.10-rc3 with that one
reverted.  wifi still broken, as expected.  Hmm.

Anyone has hints on how I can run that kind of tests automatically?  The
rpi2 I'm using is powered using a usb3 port of my x86 box, but
apparently there is no way to turn on and off power of individual usb
root ports :(


PS: The panic at boot turned out to be simple:  wrong & broken wifi
    driver.  I had the staging driver (rtl8192cu) left enabled by
    mistake, and that apparently had higher priority than the new 
    rtl8xxxu driver.  And it ran into some NULL pointer dereference.

More information about the linux-rpi-kernel mailing list