Bug in split transactions on Raspberry Pi

Alan Stern stern at rowland.harvard.edu
Tue Jan 26 10:22:57 PST 2016

On Tue, 26 Jan 2016, Noralf Trønnes wrote:

> > I installed the rpi-4.4.y branch from the
> > https://github.com/raspberrypi/linux repository.  As is, it generated a
> > working kernel.  Then I tried editing the config; I removed
> > However, when I booted the resulting kernel it didn't seem to detect
> > the host controller at all.  No USB devices were probed, which meant no
> > working ethernet or keyboard.
> >
> > Then I tried enabling both drivers in the config.  That worked, but the
> > controller was bound to dwc_otg, not to dwc2.
> >
> > I get the feeling that some magic DT incantation is missing, although I
> > have no idea what.  The base bcm2709-rpi-2-b.dtb wasn't affected by the
> > config change, nor was the overlays/dwc2-overlay.dtb file.
> >
> > Any suggestions?
> Have you enabled the dwc2 overlay?
> Add to /boot/config.txt:
> dtoverlay=dwc2

That did it!  Thank you.

The dwc2 driver seems to do a better job than dwc_otg -- at least, it 
sends Clear-TT-Buffer requests after each failure.

Doug, do you have a list of patches you'd like me to try on top of the 
rpi-4.4.y branch?

Alan Stern

More information about the linux-rpi-kernel mailing list