rpi/dwc2 kernel panics

Stephen Warren swarren at wwwdotorg.org
Fri Feb 14 00:08:21 EST 2014

On 02/13/2014 11:47 AM, Andre Heider wrote:
> On Wed, Feb 12, 2014 at 08:00:18PM -0700, Stephen Warren wrote:
>> On 02/12/2014 11:52 AM, Andre Heider wrote:
>>> Hi guys,
>>> I just tried today's Linus' master (45f7fdc2ff) with usb-linus (3635c7e2d5)
>>> merged on top to give the latest dwc2 fixes another try.
>>> Unfortunately I'm getting various crashes on system startup. Kernel boots
>>> fine, dwc2 and the integrated smsc95xx are detected, but somewhere in the
>>> init sequence the system panics.
> Which one are you using? gcc-arm-linux-gnueabi [2] or
> gcc-arm-linux-gnueabihf [3]? Maybe there's a reason the former is 4.7
> while the latter is 4.8?
> In case you're using 4.7, care to give 4.8 a try?

I tried gcc-arm-linux-gnueabihf from Ubuntu Saucy, and gcc-arm-none-eabi
from a Debian Unstable chroot, and got an apparently stable system, with
USB enabled and running "apt-get update" over USB network.

With the Saucy toolchain, I did see the following 3 times, which I
haven't seen before, but the system didn't panic:

EXT4-fs error (device mmcblk0p2) in ext4_da_write_end:2780: error 579650476

More information about the linux-rpi-kernel mailing list