[PATCH v15 02/11] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit

Manivannan Sadhasivam mani at kernel.org
Fri Sep 25 22:07:37 PDT 2026


On Tue, Sep 15, 2026 at 05:06:05PM +0200, Sebastian Reichel wrote:
> Right now the mode_change property is set whenever the mode changes
> between USB-only, DP-only and USB-DP. It is needed, because on any
> mode change the PHY needs to be re-initialized. Apparently at least
> DP also requires a re-init when the cable orientation is changed,
> which is currently not being done (except when the orientation switch
> also involves a mode change). Prepare for this by renaming mode_change
> to phy_needs_reinit.
> 
> Tested-by: Igor Paunovic <royalnet026 at gmail.com> # Orange Pi 5 Plus
> Signed-off-by: Sebastian Reichel <sebastian.reichel at collabora.com>

Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam at oss.qualcomm.com>

- Mani

-- 
மணிவண்ணன் சதாசிவம்



More information about the Linux-rockchip mailing list