[PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
Lance Yang
lance.yang at linux.dev
Thu Jul 2 05:25:15 PDT 2026
On Mon, Jun 29, 2026 at 08:25:30PM +0100, Lorenzo Stoakes wrote:
>Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer
>to a VMA is confusing.
>
>Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this
>confusion.
>
>No functional change intended.
>
>Signed-off-by: Lorenzo Stoakes <ljs at kernel.org>
>---
straight rename, no stale callers that I can spot ;) Feel free to add:
Reviewed-by: Lance Yang <lance.yang at linux.dev>
More information about the Linux-rockchip
mailing list