[PATCH v2] arm64: dts: rockchip: Fix Type-C port supply in Sapphire board

Heiko Stuebner heiko at sntech.de
Mon Sep 10 10:19:20 PDT 2018


Am Montag, 10. September 2018, 18:10:29 CEST schrieb Vicente Bergas:
> The reference is the schematic, page 11:
> https://dl.vamrs.com/products/sapphire_excavator/RK_SAPPHIRE_SOCBOARD_RK3399_LPDDR3D178P232SD8_V12_20161109HXS.pdf
> (alternate link)
> http://opensource.rock-chips.com/images/f/f0/RK_Sapphire_RK3399.rar
> 
> Changes in v2:
>  The power supply is applied to the OTG port.
> 
> Signed-off-by: Vicente Bergas <vicencb at gmail.com>

applied for 4.20


> Hi Heiko,
> your approach makes sense, i just tried it and the Type-C port is
> still powered-on, like with the previous patch.
> But sadly still no data flow.
> 
> I have got a gru/kevin and also bought a USB-C to SATA bridge
> for it. The bridge works fine on kevin with kernel 4.4, still not
> tested with mainline.
> 
> But when plugged into the Sapphire there is an LED that shows it
> is powered-on and nothing else. On the linux side, dmesg shows no
> messages.
> 
> Comparing the USB portion of the DTS wrt Firefly i see no
> significant differences.
> 
> Are there other Sapphire board users that can confirm if the
> Type-C port works or not? That would help to discard a HW issue.

Enric was working on a similar board, maybe he remember some
peculiarities.





More information about the Linux-rockchip mailing list