USB3 regression in RK3399

Vicente Bergas vicencb at
Wed Feb 21 13:58:35 PST 2018

testing on the Sapphire board, which uses the RK3399 SoC, a regression
has been found in v4.16-rc2 wrt v4.15.4 regarding the USB3 type-A port:
In v4.15.4 it works in USB2-only mode.
In v4.16-rc2 it does not work.

It has been tested with a USB2 hub with 3 devices connected:
a keyboard (USB1.1), a mouse (USB2) and a rtlwifi dongle (USB2).

It has also been tested with a USB3-to-SATA converter. This one is not
working in v4.15.4 nor in v4.16-rc2.

I have also tried the 6-patch series from Enric Balletbo i Serra
"[PATCH v3 3/6] phy: rockchip-typec: enable usb3 host during usb3 phy power on"
with the same result.

During boot, the following message appears a few times:
"dwc3: failed to initialize core"

The kernel configuration is:

Is that a configuration issue, a bug in the kernel or something else?
If it is a configuration issue, what should be changed?
If it is a bug, can it be fixed?


More information about the Linux-rockchip mailing list