dwc2 gadget issues

Francesco Lavra francescolavra.fl at gmail.com
Thu Mar 2 23:43:40 PST 2017


On Thu, Mar 2, 2017 at 6:58 AM, Randy Li <randy.li at rock-chips.com> wrote:
> You don't need to send me a private mail, I would suggest you CC me next
> time.
> On 02/24/2017 03:27 AM, Heiko Stuebner wrote:
>> Hi Francesco,
>> Am Donnerstag, 23. Februar 2017, 19:11:37 CET schrieb Francesco Lavra:
>>> I'm having trouble getting the RK3288 OTG controller (the one at
>>> ff580000) to work in peripheral mode. I'm using a Firefly Reload board,
>>> and I know the hardware is fine because I can successfully use the port
>>> in device mode with U-Boot's mass storage gadget driver.
>>> Under Linux, the OTG port works fine when used in host mode, but fails
>>> to work in device mode: nothing happens when the a USB host is plugged
>>> into the OTG port, not even a single interrupt is generated by the
>>> controller. I'm using the latest device tree definitions from
>>> git://git.kernel.org/pub/scm/linux/kernel/git/mmind/linux-rockchip.git.
>> you shouldn't use my tree as base for any real work :-) . Best to use the
>> regular mainline kernel or alternatively try linux-next to get all recent
>> usb
>> changes schedules for the next release.
>>> Tried with different gadget drivers (g_audio, g_ether, g_mass_storage),
>>> but it makes no difference.
> I tried g_ether and g_serial, it looks fine for me.

Would you mind sharing the config you used in your kernel, and what
kernel tree you are using?
I'm using the 4.10.0 mainline kernel, with the config in attachment.
Also, what RK3288 board did you try this with?


> Randy Li
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 4.10.0.config
Type: application/xml
Size: 122126 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-rockchip/attachments/20170303/dead53c5/attachment-0001.wsdl>

More information about the Linux-rockchip mailing list