[PATCH v5 5/8] clocksource/drivers/rockchip_timer: split bc_timer into rk_timer and rk_clock_event_device
al.kochet at gmail.com
Mon Jan 30 05:55:33 PST 2017
> 30 янв. 2017 г., в 16:12, Daniel Lezcano <daniel.lezcano at linaro.org> написал(а):
> I don't get the point of these changes. The patch does not explain why they are
I’d like to extract timer API from current implementation.
And to make code more readable I’d like to introduce 'struct rk_timer’ what can be
reused with current implementation and with my patch (8/8). And in order keep patches
simple and readable I split that into three patches: 5/8, 6/8, 7/8.
Current implementation named rockchip timer as ‘struct bc_timer’ (broadcast timer).
I renamed it to more suitable to it role (may be bad choice).
Yes, the patch itself looks strange. You are right.
What do you think about that solution:
- in the patch 6/8 i will Introduce 'struct rk_timer’ and 'struct rk_time_clkevt’ (renamed ‘struct bc_timer’).
- rk_timer_init() changes from 5/8 I will merge with 8/8
- 8/8 introduce 'struct rk_time_clksrc'
- 5/8 drop
More information about the Linux-rockchip