[PATCH v3 05/10] drm/rockchip: analogix_dp: add rk3399 eDP support
dianders at chromium.org
Tue Jun 14 08:24:14 PDT 2016
On Tue, Jun 14, 2016 at 4:46 AM, Yakir Yang <ykk at rock-chips.com> wrote:
> RK3399 and RK3288 shared the same eDP IP controller, only some light
> difference with VOP configure and GRF configure.
> Signed-off-by: Yakir Yang <ykk at rock-chips.com>
> Acked-by: Mark Yao <mark.yao at rock-chips.com>
> Changes in v3:
> - Give the "rk3399-edp" a separate line for clarity in document (Tomasz, reviewed at Google Gerrit)
> - Move 'output_type' setting before the return statement (Tomasz, reviewed at Google Gerrit)
> - Add the acked flag from Mark.
> Changes in v2:
> - rebase with drm-next, fix some conflicts
> .../bindings/display/bridge/analogix_dp.txt | 1 +
> .../display/rockchip/analogix_dp-rockchip.txt | 3 +-
> drivers/gpu/drm/rockchip/analogix_dp-rockchip.c | 33 +++++++++++++++++++++-
> include/drm/bridge/analogix_dp.h | 1 +
> 4 files changed, 36 insertions(+), 2 deletions(-)
> diff --git a/Documentation/devicetree/bindings/display/bridge/analogix_dp.txt b/Documentation/devicetree/bindings/display/bridge/analogix_dp.txt
> index 4f2ba8c..4a0f4f7 100644
> --- a/Documentation/devicetree/bindings/display/bridge/analogix_dp.txt
> +++ b/Documentation/devicetree/bindings/display/bridge/analogix_dp.txt
> @@ -5,6 +5,7 @@ Required properties for dp-controller:
> platform specific such as:
> * "samsung,exynos5-dp"
> * "rockchip,rk3288-dp"
> + * "rockchip,rk3399-edp"
> physical base address of the controller and length
> of memory mapped region.
> diff --git a/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt b/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt
> index e832ff9..726c945 100644
> --- a/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt
> +++ b/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt
> @@ -2,7 +2,8 @@ Rockchip RK3288 specific extensions to the Analogix Display Port
> Required properties:
> -- compatible: "rockchip,rk3288-edp";
> +- compatible: "rockchip,rk3288-edp",
> + "rockchip,rk3399-edp";
As commented by Tomasz on gerrit, there is a pre-existing typo here.
Specifically "rockchip,rk3288-edp" should be "rockchip,rk3288-dp".
The typo is pre-existing so I'm not sure you would need to spin this
series to fix it, but if you were spinning it anyway it wouldn't hurt
to fix. Could also just send out a followon patch to fix this after
the series lands...
More information about the Linux-rockchip