[PATCH v3 03/40] mm/vma: introduce and use vma_[flags_]can_merge()

Gregory Price gourry at gourry.net
Thu Sep 24 09:38:08 PDT 2026


On Thu, Sep 17, 2026 at 05:22:12PM +0100, Lorenzo Stoakes (ARM) wrote:
> Replace the open-coded VMA_SPECIAL_FLAGS check in the VMA merge logic with
> two new functions vma_flags_can_merge() and vma_can_merge() and update the
> merge logic to use the former.
> 
> This abstracts the check and expresses it in terms of the desired behaviour
> rather than an arbitrary and confusing VMA flag.
> 
> This also lays the groundwork for making further improvements in VMA flag
> usage.
> 
> Also update the userland VMA tests to reflect the change.
> 
> No functional change intended.
> 
> Signed-off-by: Lorenzo Stoakes (ARM) <ljs at kernel.org>

Reviewed-by: Gregory Price (Meta) <gourry at gourry.net>




More information about the linux-riscv mailing list