[PATCH] pwm: th1520: use vertical import style

Link Mauve linkmauve at linkmauve.fr
Wed Jul 8 00:39:25 PDT 2026


On Sun, Jul 05, 2026 at 07:52:05PM -0700, Guru Das Srinagesh wrote:
> Convert `use` imports to vertical layout for better readability and
> maintainability.
> 
> Signed-off-by: Guru Das Srinagesh <linux at gurudas.dev>
> ---
> Came across a recent commit bc58905eb07 ("samples: rust_misc_device: use
> vertical import style") and found a few more locations that could
> benefit from this cleanup. No functional changes.
> 
> Separating out patches per-subsystem as per the review feedback in [0].
> 
> Tested via:
> 
>     $ make LLVM=1 rustfmtcheck || echo "fail"
>     $
> 
> [0]: https://lore.kernel.org/lkml/20260628-b4-rust-vertical-imports-v1-0-98bc71d4810b@gurudas.dev/
> ---
>  drivers/pwm/pwm_th1520.rs | 12 +++++++++---
>  1 file changed, 9 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/pwm/pwm_th1520.rs b/drivers/pwm/pwm_th1520.rs
> index 3e3fa51ccef9..2a3b107157ac 100644
> --- a/drivers/pwm/pwm_th1520.rs
> +++ b/drivers/pwm/pwm_th1520.rs
> @@ -23,15 +23,21 @@
>  use core::ops::Deref;
>  use kernel::{
>      clk::Clk,
> -    device::{Bound, Core, Device},
> +    device::{
> +        Bound,
> +        Core,
> +        Device, //
> +    },
>      devres,
>      io::{
>          mem::IoMem,
>          Io, //
>      },
> -    of, platform,
> +    of,
> +    platform, //

Same here, you just need the empty comment after time, not the one after
platform.

>      prelude::*,
> -    pwm, time,
> +    pwm,
> +    time, //
>  };
>  
>  const TH1520_MAX_PWM_NUM: u32 = 6;
> 
> ---
> base-commit: 1a4920940ebfd8d907858abd8f8dd09b13752946
> change-id: 20260705-pwm-rust-vert-imp-59a3d18bd0cf
> 
> Best regards,
> --  
> Guru Das Srinagesh <linux at gurudas.dev>
> 
> 

-- 
Link Mauve



More information about the linux-riscv mailing list