[PATCH v4 4/7] iommu: Pass in old domain to attach_dev callback functions
Jason Gunthorpe
jgg at nvidia.com
Wed Sep 24 12:22:46 PDT 2025
On Wed, Sep 24, 2025 at 12:18:43PM -0700, Nicolin Chen wrote:
> On Wed, Sep 24, 2025 at 03:43:46PM -0300, Jason Gunthorpe wrote:
> > I've split things like this into more patches before, but this
> > actually isn't too bad, so I wouldn't push for it.
>
> Thanks. I will keep the flow in mind.
>
> For working more on the new test attach op, I'd probably keep it
> as-is.
>
> > A series version would be:
> > - add a new op 'attach_dev2' or whatever
> > - Convert all drivers that just change the signature
> > - Convert drivers that have a trivial iommu_get_domain_for_dev()
> > - N patches to convert more complex drivers one by one
> > - Remove old op attach_dev
>
> Does this mean that drivers would live with the 'attach_dev2' op
> renamed from 'attach_dev'? Or the last could rename it back?
Could rename back, often better to select a name that doesn't need a
rename back :)
Jason
More information about the linux-riscv
mailing list