[PATCH v2 0/6] RISC-V: hwprobe: Introduce which-cpus
Andrew Jones
ajones at ventanamicro.com
Fri Oct 20 06:05:16 PDT 2023
This series introduces a flag for the hwprobe syscall which effectively
reverses its behavior from getting the values of keys for a set of cpus
to getting the cpus for a set of key-value pairs. The series is based on
the patch pointed out with the tag below.
Based-on: https://lore.kernel.org/all/20231010165101.14942-2-ajones@ventanamicro.com/
Changes since v1[1]:
- Dropped copyrights when splitting hwprobe out of sys_riscv.c [Conor]
- Improved documentation [Evan]
- Fixed a bug where the set of cpus could get changed to the set of all
online cpus [Evan]
- Added check for empty set of cpus in the vdso function [Evan, drew]
- Replaced memset with a for-loop in the vdso function because we don't
have memset there [drew]
- Added an r-b from Conor
Changes since the RFC[2]:
- Split hwprobe out of sys_riscv.c into its own file [Palmer]
- Split the which-cpus functionality out of do_riscv_hwprobe() [Palmer]
- Rename hwprobe_key_is_map to hwprobe_key_is_bitmask [Evan]
- Move the homogeneous_cpus logic into the vDSO function [Evan]
- Rework logic to not need to allocate any memory
- Honor cpu affinity in the which-cpus selftests utility
- Picked up some r-b's
[1] https://lore.kernel.org/all/20231011135610.122850-8-ajones@ventanamicro.com/
[2] https://lore.kernel.org/all/20230921125518.175428-7-ajones@ventanamicro.com/
Andrew Jones (6):
RISC-V: hwprobe: Clarify cpus size parameter
RISC-V: Move the hwprobe syscall to its own file
RISC-V: hwprobe: Introduce which-cpus flag
RISC-V: selftests: Statically link hwprobe test
RISC-V: selftests: Convert hwprobe test to kselftest API
RISC-V: selftests: Add which-cpus hwprobe test
Documentation/riscv/hwprobe.rst | 28 +-
arch/riscv/include/asm/hwprobe.h | 24 ++
arch/riscv/include/uapi/asm/hwprobe.h | 3 +
arch/riscv/kernel/Makefile | 1 +
arch/riscv/kernel/sys_hwprobe.c | 357 ++++++++++++++++++
arch/riscv/kernel/sys_riscv.c | 267 -------------
arch/riscv/kernel/vdso/hwprobe.c | 86 ++++-
.../testing/selftests/riscv/hwprobe/Makefile | 7 +-
.../testing/selftests/riscv/hwprobe/hwprobe.c | 64 +---
.../testing/selftests/riscv/hwprobe/hwprobe.h | 15 +
.../selftests/riscv/hwprobe/which-cpus.c | 154 ++++++++
.../selftests/riscv/vector/vstate_prctl.c | 10 +-
12 files changed, 676 insertions(+), 340 deletions(-)
create mode 100644 arch/riscv/kernel/sys_hwprobe.c
create mode 100644 tools/testing/selftests/riscv/hwprobe/hwprobe.h
create mode 100644 tools/testing/selftests/riscv/hwprobe/which-cpus.c
--
2.41.0
More information about the linux-riscv
mailing list