[PATCH v2 0/6] riscv: alternative/cpufeature related cleanups
Andrew Jones
ajones at ventanamicro.com
Fri Feb 24 07:45:55 PST 2023
This series has no intended functional change. These cleanups were
found while renaming errata_id to patch_id in order to better
convey that its purpose is larger than errata (it's also for
cpufeatures).
Based on riscv-linux/for-next
Thanks,
drew
v2:
- Rebased on latest riscv-linux/for-next
- Add a new patch to reword the help text for RISCV_ALTERNATIVE
as suggested by Conor
- Snuck a comment cleanup into the errata_id -> patch_id patch
- Reworded commit message of the last patch [Conor]
- picked up R-b's from Conor and Heiko
Andrew Jones (6):
riscv: Clarify RISCV_ALTERNATIVE help text
riscv: Rename Kconfig.erratas to Kconfig.errata
riscv: alternatives: Remove unnecessary define and unused struct
riscv: alternatives: Rename errata_id to patch_id
riscv: lib: Include hwcap.h directly
riscv: cpufeature: Drop errata_list.h and other unused includes
arch/riscv/Kconfig | 8 +--
.../riscv/{Kconfig.erratas => Kconfig.errata} | 0
arch/riscv/errata/sifive/errata.c | 8 +--
arch/riscv/errata/thead/errata.c | 4 +-
arch/riscv/include/asm/alternative-macros.h | 72 +++++++++----------
arch/riscv/include/asm/alternative.h | 11 +--
arch/riscv/kernel/cpufeature.c | 11 +--
arch/riscv/lib/strcmp.S | 3 +-
arch/riscv/lib/strlen.S | 3 +-
arch/riscv/lib/strncmp.S | 3 +-
10 files changed, 54 insertions(+), 69 deletions(-)
rename arch/riscv/{Kconfig.erratas => Kconfig.errata} (100%)
--
2.39.1
More information about the linux-riscv
mailing list