[PATCH v2 05/13] RISC-V: rename parse_asm.h to insn.h
Conor Dooley
conor at kernel.org
Tue Nov 29 15:13:16 PST 2022
On Mon, Nov 28, 2022 at 11:26:24AM +0100, Heiko Stuebner wrote:
> From: Heiko Stuebner <heiko.stuebner at vrull.eu>
>
> The current parse_asm header should become a more centralized place
> for everything concerning parsing and constructing instructions.
Heh, I opened this mail in mutt without reading $subject and my gut
instinct was to say "parse_asm" doesn't feel like the right name for
this content...
> We already have a header insn-def.h similar to aarch64, so rename
> parse_asm.h to insn.h (again similar to aarch64) to show that it's
> meant for more than simple instruction parsing.
...and then I realised what that patch was doing :)
rg parse_asm | wc -l
0
Reviewed-by: Conor Dooley <conor.dooley at microchip.com>
Still doesn't build though due to trailing stuff from prior commits.
> Signed-off-by: Heiko Stuebner <heiko.stuebner at vrull.eu>
> ---
> arch/riscv/include/asm/{parse_asm.h => insn.h} | 0
> arch/riscv/kernel/kgdb.c | 2 +-
> arch/riscv/kernel/probes/simulate-insn.h | 2 +-
> 3 files changed, 2 insertions(+), 2 deletions(-)
> rename arch/riscv/include/asm/{parse_asm.h => insn.h} (100%)
>
> diff --git a/arch/riscv/include/asm/parse_asm.h b/arch/riscv/include/asm/insn.h
> similarity index 100%
> rename from arch/riscv/include/asm/parse_asm.h
> rename to arch/riscv/include/asm/insn.h
> diff --git a/arch/riscv/kernel/kgdb.c b/arch/riscv/kernel/kgdb.c
> index 61237aeb493c..2e0266ae6bd7 100644
> --- a/arch/riscv/kernel/kgdb.c
> +++ b/arch/riscv/kernel/kgdb.c
> @@ -11,7 +11,7 @@
> #include <linux/string.h>
> #include <asm/cacheflush.h>
> #include <asm/gdb_xml.h>
> -#include <asm/parse_asm.h>
> +#include <asm/insn.h>
>
> enum {
> NOT_KGDB_BREAK = 0,
> diff --git a/arch/riscv/kernel/probes/simulate-insn.h b/arch/riscv/kernel/probes/simulate-insn.h
> index 29fb16cd335c..a19aaa0feb44 100644
> --- a/arch/riscv/kernel/probes/simulate-insn.h
> +++ b/arch/riscv/kernel/probes/simulate-insn.h
> @@ -3,7 +3,7 @@
> #ifndef _RISCV_KERNEL_PROBES_SIMULATE_INSN_H
> #define _RISCV_KERNEL_PROBES_SIMULATE_INSN_H
>
> -#include <asm/parse_asm.h>
> +#include <asm/insn.h>
>
> #define RISCV_INSN_REJECTED(name, code) \
> do { \
> --
> 2.35.1
>
More information about the linux-riscv
mailing list