[PATCH 1/4] of: also handle dma-noncoherent in of_dma_is_coherent()
Christoph Hellwig
hch at lst.de
Sun Jun 19 23:01:27 PDT 2022
On Sun, Jun 19, 2022 at 10:32:09PM +0200, Heiko Stuebner wrote:
> bool of_dma_is_coherent(struct device_node *np)
> {
> struct device_node *node;
> + bool ret = false;
I'd rename this to coherent or is_coherent.
>
> if (IS_ENABLED(CONFIG_OF_DMA_DEFAULT_COHERENT))
> - return true;
> + ret = true;
And then do this at initialization time:
bool is_coherent = IS_ENABLED(CONFIG_OF_DMA_DEFAULT_COHERENT);
but otherwise this looks good to me.
More information about the linux-riscv
mailing list