[PATCH v3 02/11] clk: starfive: Rename "jh7100" to "jh71x0" for the common code

Hal Feng hal.feng at starfivetech.com
Thu Dec 22 22:23:09 PST 2022


On Tue, 20 Dec 2022 22:08:06 +0000, Conor Dooley wrote:
> On Tue, Dec 20, 2022 at 08:50:45AM +0800, Hal Feng wrote:
> > From: Emil Renner Berthing <kernel at esmil.dk>
> > 
> > Rename "clk-starfive-jh7100.h" to "clk-starfive-jh71x0.h" and rename
> > some variables from "jh7100" or "JH7100" to "jh71x0" or "JH71X0".
> > 
> > Signed-off-by: Emil Renner Berthing <kernel at esmil.dk>
> > Signed-off-by: Hal Feng <hal.feng at starfivetech.com>
> > ---
> >  .../clk/starfive/clk-starfive-jh7100-audio.c  |  74 ++--
> >  drivers/clk/starfive/clk-starfive-jh7100.c    | 388 +++++++++---------
> >  drivers/clk/starfive/clk-starfive-jh7100.h    | 114 -----
> >  drivers/clk/starfive/clk-starfive-jh71x0.c    | 284 ++++++-------
> >  drivers/clk/starfive/clk-starfive-jh71x0.h    | 114 +++++
> >  5 files changed, 487 insertions(+), 487 deletions(-)
> >  delete mode 100644 drivers/clk/starfive/clk-starfive-jh7100.h
> >  create mode 100644 drivers/clk/starfive/clk-starfive-jh71x0.h
> > 
> > diff --git a/drivers/clk/starfive/clk-starfive-jh7100-audio.c b/drivers/clk/starfive/clk-starfive-jh7100-audio.c
> > index 8473a65e219b..02aefb7264f8 100644
> > --- a/drivers/clk/starfive/clk-starfive-jh7100-audio.c
> > +++ b/drivers/clk/starfive/clk-starfive-jh7100-audio.c
> > @@ -16,7 +16,7 @@
> >  
> >  #include <dt-bindings/clock/starfive-jh7100-audio.h>
> >  
> > -#include "clk-starfive-jh7100.h"
> > +#include "clk-starfive-jh71x0.h"
> >  
> >  /* external clocks */
> >  #define JH7100_AUDCLK_AUDIO_SRC			(JH7100_AUDCLK_END + 0)
> > @@ -28,66 +28,66 @@
> >  #define JH7100_AUDCLK_I2SDAC_LRCLK_IOPAD	(JH7100_AUDCLK_END + 6)
> >  #define JH7100_AUDCLK_VAD_INTMEM                (JH7100_AUDCLK_END + 7)
> >  
> > -static const struct jh7100_clk_data jh7100_audclk_data[] = {
> > -	JH7100__GMD(JH7100_AUDCLK_ADC_MCLK, "adc_mclk", 0, 15, 2,
> > +static const struct jh71x0_clk_data jh7100_audclk_data[] = {
> > +	JH71X0__GMD(JH7100_AUDCLK_ADC_MCLK, "adc_mclk", 0, 15, 2,
> 
> Heh, I'm not sure what to think about these _s for alignment!

Maybe it looks clearer. These code are made previously.

> This one is a little harder to verify with my git show wizardary, but it
> also looks like it does what it says on the tin. Might've been easier to
> verify with git show if the renaming of variables and code movement had
> been split.

Should I split it?

Best regards,
Hal

> Reviewed-by: Conor Dooley <conor.dooley at microchip.com>




More information about the linux-riscv mailing list