[PATCH 2/4] clk: sifive: Use common name for prci configuration

Palmer Dabbelt palmer at dabbelt.com
Thu Nov 5 13:54:03 EST 2020


On Wed, 04 Nov 2020 18:46:56 PST (-0800), sboyd at kernel.org wrote:
> Quoting Zong Li (2020-10-16 02:18:24)
>> Use generic name CLK_SIFIVE_PRCI instead of CLK_SIFIVE_FU540_PRCI. This
>> patch is prepared for fu740 support.
>> 
>> Signed-off-by: Zong Li <zong.li at sifive.com>
>> ---
>
> Looks ok but needs an ack from riscv maintainers to go through clk
> tree. I was worried it would break defconfigs but it seems that the arch
> selects the config so this should be OK, right?

Ya, looks fine.  TBH the whole Kconfig.socs thing was probably a mistake, but
at least in this case it makes things easy.

I was going to suggest spliting the Kconfigs out so there's a _FU540_PRCI and
an _FU740_PRCI, but looking at the code it doesn't really seem to buy us much
-- just that one offset table we could toss.

Reviewed-by: Palmer Dabbelt <palmerdabbelt at google.com>
Acked-by: Palmer Dabbelt <palmerdabbelt at google.com>

>>  arch/riscv/Kconfig.socs     | 2 +-
>>  drivers/clk/sifive/Kconfig  | 6 +++---
>>  drivers/clk/sifive/Makefile | 2 +-
>>  3 files changed, 5 insertions(+), 5 deletions(-)
>> 
>> diff --git a/arch/riscv/Kconfig.socs b/arch/riscv/Kconfig.socs
>> index 8a55f6156661..3284d5c291be 100644
>> --- a/arch/riscv/Kconfig.socs
>> +++ b/arch/riscv/Kconfig.socs
>> @@ -5,7 +5,7 @@ config SOC_SIFIVE
>>         select SERIAL_SIFIVE if TTY
>>         select SERIAL_SIFIVE_CONSOLE if TTY
>>         select CLK_SIFIVE
>> -       select CLK_SIFIVE_FU540_PRCI
>> +       select CLK_SIFIVE_PRCI
>>         select SIFIVE_PLIC
>>         help
>>           This enables support for SiFive SoC platform hardware.



More information about the linux-riscv mailing list