[PATCH v13 04/12] spmi: Remove unneeded goto in spmi_device_add() error path
Abel Vesa
abel.vesa at oss.qualcomm.com
Thu Sep 17 08:41:02 PDT 2026
On 26-07-21 11:36:18, AngeloGioacchino Del Regno wrote:
> If any error happens during device_add() just return inside of the
> conditional, as the goto path doesn't do anything else if not just
> returning.
>
> While at it, to improve readability, also change this function to
> explicitly return 0 (for success) at the end.
>
> Acked-by: Stephen Boyd <sboyd at kernel.org>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko at intel.com>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
Reviewed-by: Abel Vesa <abel.vesa at oss.qualcomm.com>
More information about the linux-phy
mailing list