[PATCH 16/16] phy: qcom-qmp-usb: shorten function prefixes

Dmitry Baryshkov dmitry.baryshkov at linaro.org
Fri Sep 9 02:48:48 PDT 2022


On 07/09/2022 14:07, Johan Hovold wrote:
> The driver function prefix has gotten unnecessarily long and hurts
> readability.
> 
> Shorten "qcom_qmp_phy_" to "qmp_" (which likely stands for "Qualcomm
> Multi PHY" or similar anyway).
> 
> Signed-off-by: Johan Hovold <johan+linaro at kernel.org>
> ---
>   drivers/phy/qualcomm/phy-qcom-qmp-ufs.c |   3 +-
>   drivers/phy/qualcomm/phy-qcom-qmp-usb.c | 121 ++++++++++++------------
>   2 files changed, 60 insertions(+), 64 deletions(-)
> 
> diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> index b020409b92e0..4d0eee620f37 100644
> --- a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> +++ b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> @@ -1105,8 +1105,7 @@ static const struct phy_ops qcom_qmp_ufs_ops = {
>   	.owner		= THIS_MODULE,
>   };
>   
> -static
> -int qmp_ufs_create(struct device *dev, struct device_node *np, int id,
> +static int qmp_ufs_create(struct device *dev, struct device_node *np, int id,
>   			void __iomem *serdes, const struct qmp_phy_cfg *cfg)

This likely should go to the previous patch.

Otherwise:

Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov at linaro.org>


>   {
>   	struct qcom_qmp *qmp = dev_get_drvdata(dev);
> diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-usb.c b/drivers/phy/qualcomm/phy-qcom-qmp-usb.c
> index 08e0799e8832..41635c21e3ca 100644
> --- a/drivers/phy/qualcomm/phy-qcom-qmp-usb.c
> +++ b/drivers/phy/qualcomm/phy-qcom-qmp-usb.c
-- 
With best wishes
Dmitry




More information about the linux-phy mailing list