Problem with ide-cs

Larry Finger Larry.Finger at
Sat Jul 30 14:33:22 EDT 2011

On 07/30/2011 12:28 AM, Dominik Brodowski wrote:
> Larry,
> On Fri, Jul 29, 2011 at 11:14:20PM -0500, Larry Finger wrote:
>> With kernel 3.0, my external hard drive attached to a PCMCIA card reports
>> "irq 11: nobody cared (try booting with the "irqpoll" option)". The
>> driver in question is ide-cs. When I try irqpoll, the device works
>> correctly. Naturally, the interrupt is shared with yenta, the PCMCIA
>> adapter driver. In addition, that same interrupt is used by a BCM4318
>> Cardbus device.
>> I plan on preparing a Bugzilla entry for this problem, but I'm not quite
>> ready. What I would like to know if there is any documentation on what
>> kinds of changes are needed to fix the problem.
> Let me guess: it worked fine in 2.6.39, or .38? Output of "lspci -vv",
> "dmesg" for a working and a non-working kernel would be good starting points
> for trying to debug this issue.

It worked fine in 2.6.37 and is a regression. The bug is #40362.

I tried to bisect between 2.6.38 and 2.6.37, but didn't really get anywhere. As 
noted in the bug report, 38 and 39 lock the computer when I plug in. Only 3.0 
comes back with the nobody cared message.


More information about the linux-pcmcia mailing list