[Bug 20382] PCMCIA D-Link (O2-Micro) USB 2.0 adapter - drives not mounting - mount freezes

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Fri Oct 15 02:52:49 EDT 2010


David Bluecame <david.bluecame at gmail.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |CODE_FIX

--- Comment #3 from David Bluecame <david.bluecame at gmail.com>  2010-10-15 06:52:47 ---
Dear Wolfram.

Thank you very much! Indeed it's working now using that module option. I have
added that to my kernel line and now it works perfectly, and no need to rebuild
the kernel!

kernel /boot/vmlinuz26 root=/dev/sda1 ro yenta_socket.o2_speedup=on

I've been able to get through the 2.6.31 barrier and now I'm using

About the auto-detection, for now maybe you could just add a warning when
disabling the read prefetch/write burst in the o2 chips, so in dmesg you can
see something like "read prefetch/write burst disabled - if you have problems
mounting USB2.0 drives, re-enable it using yenta_socket option o2_speedup=on".
Probably that will help people to solve this problem if it happens to them.

For me, this bug is solved and can be closed unless you want to keep it open.

Thank you and best regards! David.

Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the linux-pcmcia mailing list