Problem with Oxford 950 2xRS232

John R. johnr at
Thu May 1 19:54:47 EDT 2008


I have a SerialGear 2 port PCMCIA card that (according to the 
manufacturer) has an Oxford 950 chip.  It should have a 16C950 UART.

I cannot get this working on my vanilla kernel (pcmciautils 
014) and a recent Ubuntu livecd (8.04).  The laptop is a Panasonic 
Toughbook CF-18.  Other PCMCIA cards work.

On insert:

May  1 18:36:35 laptop pccard: PCMCIA card inserted into slot 0
May  1 18:36:35 laptop pcmcia: registering new device pcmcia0.0
May  1 18:36:36 laptop 0.0: ttyS1 at I/O 0x3108 (irq = 9) is a 16450

Only one port detected and the UART appears to be incorrect.  I used 
setserial to change it to 16950 but had the same non-working results. 
In the code for serial_cs.c I see a reference to forcing a single port 
(I could be reading things wrong).

laptop # lspcmcia -v
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:01:00.0)
         Configuration:  state: on       ready: yes
                         Voltage: 3.3V Vcc: 3.3V Vpp: 0.0V
Socket 0 Device 0:      [serial_cs]             (bus ID: 0.0)
         Configuration:  state: on
         Product Name:   PC CARD GENERIC
         Identification: manf_id: 0x0279 card_id: 0x950b
                         function: 2 (serial)
                         prod_id(1): "PC CARD" (0x6a1d140a)
                         prod_id(2): "GENERIC" (0x346680b7)
                         prod_id(3): --- (---)
                         prod_id(4): --- (---)
Socket 1 Bridge:        [yenta_cardbus]         (bus ID: 0000:01:00.1)
         Configuration:  state: on       ready: yes

Nothing appears in lspci output for this card.  Another CardBus card 
that was tried does (and this 2xRS232 card should be CardBus).

 From /proc/interrupts:

   9:     337434    XT-PIC-XT        acpi, ehci_hcd:usb1, uhci_hcd:usb2, 
uhci_hcd:usb3, uhci_hcd:usb4, yenta, yenta, ipw2200, eth0, Intel ICH6, 
sdhci:slot0, i915 at pci:0000:00:02.0

I can provide kernel config as needed, but for sure "Support for sharing 
serial interrupts" is enabled as well as most of the options that seemed 

I tried to use minicom and kermit to access my 9600 baud devices and 
they do not work.  On *exit* of these tools I have seen one of the 
devices indicate that it has made a connection with the host computer.

 From the mailing list archives is this thread which seems similar to my 
problem (a different card):

Any ideas?



More information about the linux-pcmcia mailing list