[Bug 7306] Yenta-socket causes oops on insertion of any PCMCIA card

bugme-daemon at bugzilla.kernel.org bugme-daemon at bugzilla.kernel.org
Wed Jul 30 03:28:27 EDT 2008


------- Comment #19 from benh at kernel.crashing.org  2008-07-30 00:28 -------
So I got paulus lombard here. I booted 2.6.27-rc1 (with a couple of totally
unrelated fixes to make it build :-), with yenta built-in (couldn't be bothered
netbooting with modules), orinoco built-in, prism54 (cardbus) built-in, 8250_cs

I tried 3 cards: orinoco card worked just fine. prism54 card worked just fine,
8250 modem didn't work because it apparently failed to match it to the 8250_cs
driver, maybe it really wants modules there, I haven't looked too closely.

I'll try to investigate more tomorrow. It looks like yenta didn't pickup the
fd000000 area on my machine and that worked, but I'll see if I can make it pick
it up. It's possible that the firmware is lying and that this range hasn't
actually been enabled on the bridge. I'll have a look.

Also make sure your config file doesn't try to feed ranges to the kernel
driver, that's obsolete, it should be able to find free ones all by itself.

Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the linux-pcmcia mailing list