pcnet_cs: use axnet_cs instead

Diego Rondini panda84 at inwind.it
Fri Jan 25 13:01:46 EST 2008

Hi all there! :)

I've searched and tried lot of things before posting here, but nothing 
So I'm going to summary my problem that is a possible pcmciautils bug.

I have a PCMCIA net card with no brand. During boot up kernel says:

pcnet_cs: this is an AX88190 card!
pcnet_cs: use axnet_cs instead.
pcnet_cs: unable to read hardware net address for io base 0x300

During pcmcia-cs days (long time ago) the problem was simply fixed 
adding these lines in config.opts:

card "Network card"
    version "PCMCIA", "Fast-Ethernet"
    manfid 0xffff, 0x1090
    bind "axnet_cs"

and at reboot everything worked fine. No need even to blacklist pcnet_cs.

 From the coming of 2.6.13 kernel and pcmciautils I didn't managed to 
find a way to make this card working.
I studied udev rules, but these aren't the problem as no card is present 
in /sys/class/net/ except (obviously) lo.
I tried manually blacklisting pcnet_cs (with success) and manually 
modprobing axnet_cs (with success) but still no interface is found in 

I'm asking here because the problem seems to be related from the change 
from pcmcia-cs to pcmciautils.

Thank you very much.

P.S.: if you need more infos about quite the same problem (same error, 
similar cards):
Source file triggering "pcnet_cs: use axnet_cs instead"

More information about the linux-pcmcia mailing list