CardBus cards not detected, PCMCIA cards are

Jonathan Jara-Almonte jonjara at
Mon Jun 12 08:55:04 EDT 2006

On Monday 12 June 2006 02:58, you wrote:
> Hi,
> Jonathan Jara-Almonte wrote:
> >Hi, I have a Compaq Presario 2100US (PCMCIA bridge is O2Micro
> >OZ601/6912/711EO) and also 3 diferent cards: 1 PCMCIA 56k/fax card, one
> >D-Link 10/100Mbps ethernet adaptop, and 1 Linksys WPC54G ver. 3 wireless
> >adaptop. If I insert the 56k/fax card it is detected and a card entry
> > appears in lspcmcia and information appears when I run pccardctl
> > info/ident. pccardctl status reports it as a 5V 16bit PCMCIA card. On the
> > other hand when I put in either of the other cards, no entry for them
> > appears and the only info I can find listed about them is that pccardctl
> > status sees a 3.3V 32bit CardBus card. How should I go about getting
> > these cards working (I'm most concerned with the wireless card the others
> > I don't really care about).
> I had a similar problem. In my case "lspci" didn't list the cardbus
> card, however "lspci -H1" did.
> Look up the pci detection options in the lspci man page (-H1, -H2, -M,
> if I remember correctly)
> and try all of them. If any of them works, try booting with an
> appropriate pci=??? parameter (??? might
> be conf1,conf2, bios, nobios and maybe some other options which I don't
> remember). In my
> case pci=conf1 did the trick.

Hi, just tried this but it didn't work. I have found out though that even 
though it sees my CardBus bridge as a bridge to 02-05 there is no line about 
entering these domains (if that is the correct term). On the otherhand, my 
graphics card has a PCI bridge to 01-01 and directly below that information 
is a line saying 

01: Entered via 00:01.0

Is this anything important or is it normal for it not to enter if it doesn't 
see anything?


More information about the linux-pcmcia mailing list