Problem with 16-bit cards on Tecra 530CDT: unable to apply power

Richard Barrington richard at
Tue Apr 19 01:11:30 EDT 2005


I know I'm replying to an ancient post, but I've just had the same 
problem on a Toshiba Tecra CDT510. It also uses the TOPIC95 bridge. 
Kernel is Ubuntu 2.6.10-5-386.

Things worked fine with a DSE RealTek chipset PCMCIA NIC and Yenta 
driver, but gave the "unable to apply power error" with a Brightcom 
PCMCIA modem (Intel MD566X chipset). I've worked around it by changing 
the BIOS setting to "PCIC" and loading the i82365 bridge driver. The 
modem now works fine, but unfortunately the NIC is no longer found...


>I have installed Fedora Core 2 on a Toshiba Tecra 530CDT laptop, which 
>uses a TOPIC95 PCMCIA bridge. I'm trying to get a couple of 16-bit 3Com 
>cards (3C589D and 3C574TX) to work properly, but keep getting the 
>following message when I insert one of the cards:
>kernel: cs: pcmcia_socket0: unable to apply power
>The TOPIC95 BIOS setting is set to "CardBus/16-bit". I also have a 
>CardBus 3Com card (3C575) which works fine. I have tried both the 2.6.5, 
>2.6.6 and 2.6.7 kernels distributed with FC2, as well as configured and 
>compiled 2.6.8-rc3. The same problem exists in all versions. Does anyone 
>know more about this, or have any help to offer?

More information about the linux-pcmcia mailing list