Linux 2.6.x / EnE CB1410 cardbus - No Interrupts

Jeff Noxon jeff at
Sun Mar 21 15:10:30 GMT 2004

Ok, since I have had success in two desktop systems, I am back to my
"target" low-profile-pci system.  It contains an Intel D845GLLYL board.
I have applied the latest BIOS (P17).  Notes below apply to kernel 2.6.4.

With the "pcmcia-ti-routing-9" patch, as well as the PCI ID (TI_1250)
patch, I get this:

Linux Kernel Card Services
  options:  [pci] [cardbus]
PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
Yenta: CardBus bridge found at 0000:01:00.0 [0000:0000]
Yenta: Enabling burst memory read transactions
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:01:00.0, mfunc 0x00000000, devctl 0x46
Yenta TI: socket 0000:01:00.0 probing PCI interrupt failed, trying to fix
Yenta TI: socket 0000:01:00.0 falling back to parallel PCI interrupts
Yenta TI: socket 0000:01:00.0 no PCI interrupts. Fish. Please report.
Yenta: ISA IRQ mask 0x0000, PCI irq 0
Socket status: 00000000

Without the "pcmcia-ti-routing-9" patch, but with the TI_1250 patch,
I get this:

Yenta: CardBus bridge found at 0000:01:00.0 [0000:0000]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta: ISA IRQ mask 0x0000, PCI irq 21
Socket status: 00000000

In both cases, `cardctl status` returns:
Socket 0:
  no card

There is only one socket, however, the Tulip cardbus card is inserted
in the socket.  Whereas the card is detected (and with the patches, works)
on the other two machines I have tried, the card is never detected on this

I have also tried booting with command line variations like:

acpi=off noapic pci=biosirq (failed as in first case, IRQ=0)
acpi=off noapic pci=biosirq pci=usepirqmask (failed as in second case, IRQ=10)

Without any kernel options (acpi enabled) I get the following with lspci:

01:00.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 168, Cache Line Size: 0x20 (128 bytes)
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at 3ff01000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=01, secondary=02, subordinate=05, sec-latency=176
        Memory window 0: 40000000-403ff000 (prefetchable)
        Memory window 1: 40400000-407ff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
        BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
        16-bit legacy interface ports at 0001

/proc/interrupts, without the TI IRQ routing patch (with the patch,
yenta has no IRQ):

root at gw:~# cat /proc/interrupts
  0:    1092062    IO-APIC-edge  timer
  1:          8    IO-APIC-edge  i8042
  2:          0          XT-PIC  cascade
  8:          1    IO-APIC-edge  rtc
  9:          0   IO-APIC-level  acpi
 14:      80904    IO-APIC-edge  ide0
 16:          0   IO-APIC-level  uhci_hcd
 18:      22267   IO-APIC-level  uhci_hcd, eth2
 19:      29645   IO-APIC-level  uhci_hcd, eth0
 20:      23594   IO-APIC-level  eth1
 21:          0   IO-APIC-level  yenta
 23:          0   IO-APIC-level  ehci_hcd

I have tried two different PCI slots.  The board has 4 slots, but the
card only physically fits into two of them due to capacitors on the
mainboard in the way of the PC card slot.

I will apply the other patches and follow up.

When you say "Daniel's patches" are you referring specifically to the
TI IRQ routing patch above, or are there others?



On Sat, Mar 20, 2004 at 08:14:56PM +0000, Russell King wrote:
> On Sat, Mar 20, 2004 at 12:28:30PM -0600, Jeff Noxon wrote:
> > I have tried these two patches with no success.  The system behaves
> > exactly the same as I described before.
> Could you provide us with some updated kernel messages (with both my
> and Daniel's patches applied).

More information about the linux-pcmcia mailing list