"unable to apply power" problem in 2.6.6

Russell King rmk+pcmcia at arm.linux.org.uk
Sat Jun 19 17:14:10 EDT 2004

On Sun, Jun 20, 2004 at 04:44:16AM +0930, Ryan Verner wrote:
> Ryan Verner wrote:
> > I probably should have posted this with the original email, but under 
> > 2.4, the error is "cs: unable to map card memory!".  I've tried all the 
> > usual changes to /etc/pcmcia/config.opts but to no avail.
> Last time I reply to myself, promise :-)
> Just tried the patch Russell posted against 2.6.6, and compiled a new 
> kernel; no difference, same problems. :-(

The patch wasn't designed to specifically fix the problem, but to try
harder to turn the power on and report what was going on.  The kernel
messages from it may provide a hint, but I somehow doubt it from what
you're saying.

It seems that some cardbus controllers just get stuck and refuse point
blankly to enable power to the socket without reporting why they're
refusing to.  At present, I've no idea why they're behaving in that
way.  So far, everything suggests that the CPU side looks fine
_except_ they just won't turn the power on.

(and then there's the converse problem where some controllers decide
they're not going to turn the power off when we ask...)

Russell King
 Linux kernel    2.6 ARM Linux   - http://www.arm.linux.org.uk/
 maintainer of:  2.6 PCMCIA      - http://pcmcia.arm.linux.org.uk/
                 2.6 Serial core

More information about the linux-pcmcia mailing list