Having problem with a sever which has 18 PCI slots to run 18 PCMC IA cards

Randy.Dunlap rddunlap at osdl.org
Wed Dec 15 19:48:46 EST 2004

Khamar, Kalpit K (Kalpit) wrote:
> Hi All,
> I am trying to configure server to use 18 PCMCIA cards on one server which has 18 PCI slots.
> I am running kernel 2.6.9-1.667smp (Fedora core 3) and each time i am able to add only 11 PCI to PCMCIA Elan digital P222 adapters. When i add 12th adapter i am getting kernel error message.( it's shows at the bottom). Before that i am having problem to recognize only 4 PCMCIA cards out of those 11 PCMCIA adapters. All the time i am able to see PCMCIA cards from PCI slot 1st 2nd 9th and 10th. I tried using Fedora core 2 and i got the same result All the time only those 4 PCI slots are able to see PCMCIA cards.
> So i have 2 problems. First why i am not able to see all 11 PCMCIA cards i all PCI to PCMCIA adapters. What i have to do to fix that issue?
> And second why only first PCI slots able to see PCI to PCMCIA Elan digital P222 adapters. How can i fix the kernel error message which i am getting at boot time which is mention below.
> Please let me know if you need more information.
> Thanks
> Kalpit
> lspci -v output

I'd like to see lspci -x output for the Cardbus bridges...

> 02:0e.0 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 02)
>         Subsystem: Unknown device 414e:454c
>         Flags: bus master, medium devsel, latency 168, IRQ 153
>         Memory at f8700000 (32-bit, non-prefetchable) [size=4K]
>         Bus: primary=02, secondary=47, subordinate=4a, sec-latency=176
>         Memory window 0: f8701000-f8702000 (prefetchable)
>         Memory window 1: f8703000-f8704000
>         I/O window 0: 0000d000-0000d103
>         I/O window 1: 0000d200-0000d303
>         16-bit legacy interface ports at 0001

That's an unfortunate I/O window size (wastes lots of IO space).

> Kernel error message which i get when i try to use 12th PCI to PCMCIA adapter.
> Call Trace:
> [<0220d98c>] class_device_create_file+0x11/0x16
> [<021b6c3b>] pci_alloc_child_ubs+0x74/0xb8
                               _bus (garbled !?!?!)
> [<021b6d2e>] pci_scan_bridge+0x90/0x1bb
> [<021b72ef>] pci_scan_child_bus+0x51/0x77
> [<021b6d56>] pci_scan_bridge+0xb1/0x1bb
> [<021b72ef>] pci_scan_child_bus+0x51/0x77
> [<021b7449>] pci_scan_bus_parented+0x113/0x129
> [<022609c0>] pcibios_scan_root+0x3b/0x42
> [<02390214>] pci_legacy_init+
> [<023757e1>] do_initcalls+0x32/0x80
> [<021004f8>] init+0xbd/0x1f3
> [<02100452>] init+0x0/0x1f3
> [<021041f1>] kernel_thread_helper+0x5/0xb
> Code: 74 15 8b 46 0c 85 c0 74 07 31 d2 e8 1d 81 fb ff 89 f0 e8 71 bb fb ff 3b 31 c0 5e c3 55 31 c9 89 c5 57 89 d7 ba 6b 00 00 00 56 53 <8b> 70 10 b8 c2 3b 2c 02 e8 f8 87 f9 ff 8d 5c 70 e8 7d 27 13 00

Before the Call trace, there should be a kernel oops or panic
or BUG message.  Please post the full message log for the crash.


More information about the linux-pcmcia mailing list