SMC2532 not recognized

Dan Christian robodan at
Mon Aug 30 20:16:19 EDT 2004

I just picked up a SMC2532 card with a PCMCIA to PCI adapter.  All my research 
suggested that this card should work just fine under Linux.  

However, pcmcia doesn't know what to do with it.  I've tried it under Fedora 2 
(Ricoh Co Ltd RL5c475 (rev 80)) and Fedora 1 (Texas Instruments PCI1410).  

Another card (IDE) works fine in both systems, so the basic pcmcia support 
seems to work OK.  I tried loading orinoco, orinoco_cs, and hermes by hand 
(no errors or messages of any kind); but iwconfig never showed the interface.

Is this some new/unsupported version of the card?  Or am I just doing 
something wrong?

I'm not on the list.  Please CC me.


Here are the details from the card:
Model No: SMC2532W-B
Part No: 99-012084-184
FCC ID: M4Y-0325H

Details from online probes:
[root at MacCready wireless]# cardctl status
Socket 0:
  5V 16-bit PC Card
  function 0: [ready], [bat low]

[root at MacCready wireless]# cardctl ident
Socket 0:
  product info: "SMC", "SMC2532W-B EliteConnect Wireless Adapter", "", ""
  manfid: 0xd601, 0x0005
  function: 6 (network)

[root at MacCready wireless]# cardctl info
PRODID_2="SMC2532W-B EliteConnect Wireless Adapter"

[Fedora 2 system]# uname -a
Linux MacCready 2.6.8-1.521 #1 Mon Aug 16 09:01:18 EDT 2004 i686 athlon i386 

[Fedora 1 system]# uname -a
Linux wright 2.4.22-1.2197.nptl #1 Thu Jul 1 15:14:28 EDT 2004 i686 i686 i386 

More information about the linux-pcmcia mailing list