PCI IRQ routing change broke PCMCIA/prism54 driver

Cyrille Chépélov cyrille at chepelov.org
Sun Aug 15 12:06:26 EDT 2004

Russell King wrote:

> Ok, still need more information though - eg, whether the IRQ count in
> /proc/interrupts increases for packets received.
> However, if packets are received, that seems to suggest that IRQs are
> working, and the problem has been caused by some other change - maybe
> in the Prism54 drivers themselves?

Hmmm. This is where things start getting really weird. I wanted to run a 
  grand test campaign, with lspci -vv and -vt, the card in the lower and 
upper slots, with and without pci=routeirq and a 1-second sampling of 
/proc/interrupts over 1 minute, so I started booting the computer 
without pci=routeirq.

It still runs that way (I'm typing this e-mail on it). Urgh.

Tried to reboot, same deal.
Shut down the computer, pulled the battery, waited a couple minutes, 
plugged stuff back in, booted without pci=routeirq, same deal.

I have always used the same version of the kernel (2.6.8-rc4-mm1) since 
I started sending the report to Bjorn. But now the problem appears to be 

The only ingredient I haven't yet exercised (since I tried to reproduce 
the problem) is that the machine did not go into swsusp yet. It is 
possible (I don't quite remember) that the first time I booted 
2.6.8-rc4-mm1, was after the previous version woke up. Or that the 
problems started after a suspend & wake up + reboot, or something like 
that. I will keep investigating for a while, and will report if anything 
new turns up.

	-- Cyrille

More information about the linux-pcmcia mailing list