[Linux-parport] Hp 5100c not recognized

marco pisciu at gmail.com
Fri Jan 6 09:49:35 EST 2006


(first, sorry for my bad english)

I tried in this week to get my parallel port scanner (HP 5100c) working on my system.
I am working on a Pentium III PC with ubuntu Breezy 5.10 and a 2.6.12 kernel.
I've followed this post: 


and everything works properly:
i sucessfully installed the modules with modprobe (with insmod i've had many problems):

modprobe scsi_mod
modprobe sg
modprobe parport
modprobe parport_pc
modprobe ppscsi

with this result (see with dmesg):

[4294970.382000] SCSI subsystem initialized
[4294970.434000] ppSCSI 0.92 (0.92) installed

but when i try to loading the last modules the shell response is:

modprobe onscsi
FATAL: Error inserting onscsi (/lib/modules/2.6.12-10-686/kernel/drivers/parport/onscsi.ko): No such device

I've tried many ways but the result are always the same. I haven't no idea about. Can anybody help me?
(i must say that the scanner is properly connected and works fine under windows)



More information about the Linux-parport mailing list