[Linux-parport] Parport signals stability with SiS chipset

tdlt at cecm.usp.br tdlt at cecm.usp.br
Tue Mar 16 22:15:03 GMT 2004

	I have two computers with SiS chipsets and both of them have the
	same problem.

	When I try to send the data through the parallel port inside a
	while(1), the state of the pins is as I would like they to be,
	showing that the port sends the data, but not maintain the pins

	Under MS-Windows the stability of pins voltage is OK.

	I have problems printing large images using the parallel port in
	ECP or EPP mode, so I use this in SPP mode and I believe it is
	related to our problem with pins voltage...

	A workaround is to connect the port to a latch IC (i.e.
	74373, 74374) and use one of the control pins as gates. I tried
	this and got good results (except that I cannot use one of the
	control pins). In your case it would work once you would make
	the program to control the jtag (at least is what I think).

	I don't know what is the problem with the SiS chipset and the
	Linux, but I tried this with kernel 2.2.21 and the problem is 
	within it too, showing that the problem was not perceived or
	reported once before.

	I can help with the electronic solution (latch), but I don't
	know so much about Linux kernel source to help with the

	Thank you all.

On Mon, Feb 09, 2004 at 11:24:49AM +0100, Eric BENARD / Free wrote:
> Hi !
> I'm trying to get a small jtag software to run under Linux and I meet problems 
> with the parallel port :
> - on two PC (a Dell Intel based Notebook and an Asus VIA/AMD based), 
> everything is ok, I can write and read correct data to the board (an ARM7 
> cpu)
> - on the other PC (Asus Pundit with SiS651/962 chipset & Celeron4 CPU), the 
> parport IO are always swinging so data gets corrupted.
> Both PC have the same settings (SPP). I tried with 2.4.23 & 2.6.1 & 2.6.2 
> kernels on the Asus without any success.
> I quickly tested on a SiS630 PC and I have the same problems than on the 
> Pundit, so this could come from a problem with the SiS chipset handling 
> parport.
> Of course, I checked that no other software was trying to use the parport. I 
> unloaded lp, and only ppdev is loaded.
> The problem is the same if I try to access the parport directly (io @ 0x378) 
> or through ppdev (/dev/parport0).
> Here is the schematic used for the JTAG adapter : 
> http://axl.freeyellow.com/iPAQ/xilinx-DLC5-pp2jtag.pdf
> Do you have an idea of what could be wrong ? Or maybe where I should look to 
> get more details and solve this problem ?
> Many thanks for your help & best regards
> Eric

Thiago A. M. Delatorre

More information about the Linux-parport mailing list