[Linux-parport] parport_pc disables Hercules mode of mdacon on one pentium

Sindi Keesan keesan at iamjlamb.com
Fri Jul 23 17:47:19 EDT 2004

On Fri, 23 Jul 2004, Adam Baker wrote:

> On Friday 23 July 2004 01:39, Sindi Keesan wrote:
> > I should perhaps have informed those not familiar with these cards that
> > Hercules cards INCLUDE a parallel port set to IRQ 7. It takes over as LPT1
> > unless you can find some way to disable it (and usually there are no
> > jumpers or they are unlabelled).  The onboard parallel port then becomes
> > LPT2.  They seem to share an IRQ okay.  I have done plip with this HCG
> > parport (but don't know how to do it with LPT2).  On one HGC card plip did
> > not work though laplink pro worked.  On another card the parport was dead.
> >
> I was going to ask if it was one with a builtin parport and then thought that 
> just because I vaguely remembered such a beast from the distant past that 
> that probably wasn't the exact card you were referring too. In that case I 
> would have a further concern that it doesn't support ECP and EPP modes and 
> that the drivers automatic probing for such modes may be writing to registers 
> used by the card for other purposes. If that is the case then the patch I 
> have got half written to allow specifying the mode as a parameter instead of 
> probing might help. I've been writing it for a 2.6 kernel, I don't know if 
> parport_pc has changed much since 2.2 so I don't know how difficult it would 
> be for you to apply if I ever finish it.

I don't know how to disable the Hercules card parport so I have to use it 
as LPT1.  If you want me to test out the module for 2.2.16 you will have 
to compile it for me.  I attempted once to compile winbond840 and got a 
lot of error messages and gave up. 

 > >
> > I will attempt to do this.  Presumably the io address is the same as the
> > BIOS default for the onboard LPT1 (378).
> > insmod parport_pc io=0x378 irq=7
> > (My guess is based on a beginner's experience with ISA ethernet cards).

> You can verify that relatively easily yourself - here is an example from my 
> machine.
> $ dmesg | grep -i parport
> parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
> parport0: irq 7 detected

I get parport0: PC-style at 0x378 [SPP] I don't get anything about the
IRQ.  I have to assign that separately when using plip. (insmod parport_pc
echo 7 > /proc/parport/0/irq). Could I not need to assign it if I put irq7
on the insmod line?  I have switched to ethernet because I was unable to
transfer one large file (fs.img used in a loop style linux) via parallel
port - it kept changing the file.  

insmod parport_pc io=0x378  fixed my problem.  mdacon works now.

Thanks for helping me set up one perfect computer.  Three others (same
model) either won't usually work with loadlin unless I boot with Win98 DOS
(except some of the time they boot from DR-DOS - do you have a solution to
that problem???), one won't work with HGC, and some have only two ISA
slots.  This has four - for scanner card, modem, sound card and HGC!

If it would help you I can try two other HGC cards in the same computer
and let you know if they work with mda and without io=0x378 and if they
are also only [SPP].  And report on the specifics of the cards (chip 

Not very related, but do you have any ideas why the parport on one
Hercules-type card would work with laplink pro (DOS) but not plip?  
Should I try specifying io on the insmod line in that case too?

Thanks again

More information about the Linux-parport mailing list